Thursday, September 3, 2009

Error while trying to run project: Unable to start debugging on the web server. The project is not configured to be debugged.

Error: Error while trying to run project: Unable to start debugging on the web server. The project is not configured to be debugged.

Cause: Either debug is not enabled in your web.config (OR) For some reasons IIS is not considering your web application as a virtual directory. Instead it is considering it to be a normal folder.

Solution 1:

Step 1: Open the web.config
Step 2: If debug is set to "false" change it to "True".

For example: In web.config I have a line like this I would change it to

If at all this doesn't work. Try out the next solution.

Solution 2:

1.From the Start menu, choose Programs, then Administrative Tools, and click Internet Information Services.

2.In the Internet Information Services dialog box, click the tree control for your machine, open the Web Sites folder, and find your web site.

3.Right-click Web Site and choose Properties.

4.In the Web Site Properties window, select the Directory tab.

5.Under Application Settings, look for the Remove or Create button. If the button says Remove, your website is already configured as an application. If the button says Create, click the button to configure your website as an application.

6.Click OK.

If it also doesn't work, try the next solution.

Solution 3:

If you are running Visual Studio 2003 (or ASP.NET v1.1) you should setup IIS to use ASP.NET v1.1 and not ASP.NET v2.0

May be you have installed .NET framework 1.1 as well as 2.0 in your box and trying to run an application via VS.NET 2003. If so, then do the following:

Step 1: Start >> Run >> inetmgr
Step 2: Navigate to the virtual directory of the project which is throwing this error.
Step 3: Right click on the virtual directory and choose "Properties"
Step 4: Choose the tab ASP.NET
Step 5: The first dropdown would read "ASP.NET Version", choose 1.1.4322


Solution 4 :

1. go to the C:\WINNT\Microsoft.NET\Framework\
2. and run aspnet_regiis.exe /i
That's it. Hope this helps.

No comments:

Shared Button